Документация для GNOME развитие расширение оболочки?

Я давно хотел развить некоторые гнома расширений оболочки, так как они являются только в JavaScript, но я искал и там практически ноль документацию, везде я смотрю люди просто говорят, чтобы использовать основной документации GNOME, но это не помогает, я не могу найти любую документацию для импорта для расширения, или какой-либо код JavaScript API для расширения, развития, я пытался через некоторые учебники (большинство из которых для GNOME 3.0, а не 3.2), но ничего не помогает.

Кто-нибудь знает, если они в процессе написания документации для разработки расширений? Я бы очень хотел хороших документация...

+279
Matthew Cloner 30 мая 2016 г., 8:59:13
16 ответов

Почему у нас разные версии PHP.ini для PHP-клиент ?

Это хорошая идея, чтобы связать, а ?

$ судо ЛН-Ы /и т. д./В php5/apache2 не/РНР.Ини файле /etc/php5 с/под/РНР.Ини
+986
beist87 03 февр. '09 в 4:24

Я не хочу, чтобы имена файлов должны быть завершены в моей черточки единства, для обеспечения конфиденциальности и безопасности.

Есть ли способ, чтобы отключить файлы могут быть показаны в тире?

Обратите внимание, что я в состоянии скрыть недавно использовавшихся документов из приборов, используя настройки приватности. Что меня интересует, прячет все документы от черточки.

+985
Christian Amestegui 18 нояб. 2015 г., 0:38:36

Я был из петли Ubuntu для вполне некоторое время теперь, и теперь совершенно новый ноутбук. Установил Ubuntu 12.04 64-bit и хочу выводить видео и аудио через HDMI на телевизоре. следующую команду lspci | grep в разъем VGA для моего компьютера. скажите, пожалуйста, если есть какая-то дополнительная информация нужна и, желательно, как получить это и я буду более чем счастлив обязать. заранее благодарим Вас за ваше время и помощь в этом вопросе.

00:02.0 VGA совместимый контроллер: корпорация Intel 2-го поколения Core семейство процессоров интегрированный графический контроллер (пересм 09)
01:00.0 VGA совместимый контроллер: компания NVIDIA GF108 [GeForce для 540m и GT] (откр А1)

Редактировать: каждый раз, когда я перезагрузки моего компьютера, через короткое время, я получаю сообщение об ошибке, гласящее что-то вроде "извините, жокей, необходимых, чтобы закрыть неожиданно." после исследования, я обнаружил, что жокей-это имя из "дополнительных драйверов", который после начальной установки, Убунту сообщил мне, фирменных драйверов. те, которые больше не доступны, и эта ошибка продолжает возникать.

+874
Michael Andorfer 2 нояб. 2014 г., 3:27:01

Я, кажется, не додумались решение с оговоркой. Подробности ниже.

  1. Использовать gconftool-2 для настройки /приложения/перевод/global_keybindings/panel_main_menu на клавиши super_l (как вы упомянули в своем вопросе.
  2. Установите xvkbd пакет через судо способность установить xvkbd
  3. Используйте эту команду: (Система -> Параметры -> менеджер настройки Compizconfig), чтобы создать новую команду, привязанные к АЛТ+Ф1. Против команды -> команды -> команды 4 Введите xvkbd -текст "\[клавиши super_l]" и против команды -> комбинации клавиш -> выполнить команду 4 выбран F1 клавиш.

Это должно работать. Она почти полностью скопирована с этого ubuntuforums пост.

Осторожно

Когда я попытался это в моей системе, я нашел 1 Очень странный вопрос. В системном начал вести себя так, как если бы клавиша alt на постоянной основе (например, я мог бы просто нажать для переключения между окнами). Я не уверен, что это потому, что я ранее упоминал xvkbd, чтобы имитировать клавишу Alt нажимает. Если вы сталкиваетесь с этой проблемой, единственный вариант я нашел, чтобы использовать систему снова был следовать ниже шаги.

  1. Падение к терминалу, нажав сочетание клавиш Ctrl+АЛТ+Ф1

  2. Войдите с вашим именем пользователя и паролем

  3. Силу выхода и перезапуска X, выполнив следующую команду.

    судо рестарта ГДМ
    

Если проблема сохраняется после входа в систему, то вы можете использовать следующую команду, чтобы сбросить отображение super_l чтобы panel_main_menu (к defauly АЛТ+Ф1) gconftool --снятие /приложения/перевод/global_keybindings/panel_main_menu

+864
Norm Koerner 19 нояб. 2010 г., 8:48:43

Я недавно установил Ubuntu 12.04 (первый раз на Ubuntu).

У меня обычный "администратор", а другую учетную запись "гость".

Я экспериментировал сегодня с учетными записями пользователей, и установить "учетная запись администратора" для "стандартных" в настройках учетной записи пользователя.

Теперь всякий раз, когда что-то просит меня для проверки подлинности, это дает мне сообщение об ошибке.

Я использую тот же старый пароль, не создавать новые учетные записи, просто поменяли права. Я уверен, что пароль правильный, потому что я все еще могу войти.

Я попытался войти в корень из терминала, но это дало мне, что я не один из пользователям использовать sudo?.

+821
Caraline Kupp 12 янв. 2018 г., 20:12:21

Разве в GNOME есть функция, которая позволяет мне парить над окном на панели задач и выберите его без нажатия? Спасибо!

+739
vi4m 22 мая 2015 г., 20:20:50

Я случайно сломал libbglib2.0-0, пытаясь установить новую версию пакета в Debian. Сейчас я ничего не могу сделать.

Вот что я сделал:

судо команды dpkg -я libglib*.деб
(Чтение базы данных ... файлы 503232 и каталоги установлены.)
Готовится сменить libglib2.0-0 2.30.0-0ubuntu4 (используя libglib2.0-0_2.33.12+really2.32.4-5_amd64.деб) ...
Де-настройка libglib2.0-0:i386 с ...
Распаковка libglib2 замены.0-0 ...
с dpkg: ошибка обработки libglib2.0-0 (--установки):
 libglib2.0-0:amd64 в 2.33.12+really2.32.4-5 не может быть настроен, потому что libglib2.0-0:i386 находится в другой версии (2.30.0-0ubuntu4)
с dpkg: ошибка обработки libglib2.0-0:для i386 (--установки):
 libglib2.0-0:i386 в 2.30.0-0ubuntu4 не может быть настроен, потому что libglib2.0-0:amd64-это в другой версии (2.33.12+really2.32.4-5)
Ошибки возникли при обработке:
libglib2.0-0
libglib2.0-0:i386 в

--

суда apt-получить -Ф установите
Списки Readingpackage... сделано
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Исправление зависимостей... не удалось.
Следующие пакеты имеют неудовлетворенные зависимости:
 libglib2.0-0 : зависит: libffi5 (>= 3.0.4) но его невозможно установить
 Перерывы: libglib2.0-0:для i386 (!= 2.33.12+really2.32.Установлено 4-5), но 2.30.0-0ubuntu4 будет 
 libglib2.0-0:i386 с : перерывы: libglib2.0-0 (!= 2.30.0-0ubuntu4) но 2.33.12+really2.32.Установлен 4-5-это 
 libglib2.0-ОГРН : зависит: libglib2.0-0 (= 2.30.0-0ubuntu4) но 2.33.12+really2.32.Установлен 4-5-это 
 libglib2.0-в dev : зависит: libglib2.0-0 (= 2.30.0-0ubuntu4) но 2.33.12+really2.32.Установлен 4-5-это 
Е: ошибка, pkgProblemResolver::решения образующихся разрывов, это может быть вызвано пакетов.
Е: невозможно исправить зависимости

--

судо apt-получить установку libglib2.0-0
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
libglib2.0-0-это уже новейшая версия.
Возможно, вы захотите воспользоваться 'apt-получить -Ф Install' для исправления этих:
Следующие пакеты имеют неудовлетворенные зависимости:
 libglib2.0-0 : зависит: libffi5 (>= 3.0.4) но его невозможно установить
 Перерывы: libglib2.0-0:для i386 (!= 2.33.12+really2.32.4-5), но 2.30.0-0ubuntu4 будет установлен
 libglib2.0-0:i386 с : перерывы: libglib2.0-0 (!= 2.30.0-0ubuntu4) но 2.33.12+really2.32.4-5 должен быть установлен
 libglib2.0-ОГРН : зависит: libglib2.0-0 (= 2.30.0-0ubuntu4) но 2.33.12+really2.32.4-5 должен быть установлен
 libglib2.0-в dev : зависит: libglib2.0-0 (= 2.30.0-0ubuntu4) но 2.33.12+really2.32.4-5 должен быть установлен
Е: неудовлетворенные зависимости. Попытайтесь выполнить 'apt-получить -установить Ф' без упаковки (или указать решения).

Что мне делать? В значительной степени все зависит от Глеба.

Редактировать: я попробовал то, что первый комментатор сказал и получил такой результат:

судо apt-получить установку -Ф libglib2.0-0=2.30.0-0ubuntu4
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующий пакет был установлен автоматически и больше не требуется:
libpanel-апплет-4-0
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
Следующие пакеты будут понижены:
libglib2.0-0
0 обновлено, 0 установлено новых, 1 понижен, 0 для удаления и 1 пакетов не обновлено.
3 не полностью установлены или удалены.
Нужно получить 0 б/1,169 КБ архивов.
После этой операции, 265 КБ дискового пространства будет освобождена.
Вы действительно хотите продолжить [д/н]? г
с dpkg: предупреждение: понижение libglib2.0-0 с 2.33.12+really2.32.4-5 до 2.30.0-0ubuntu4.
(Чтение базы данных ... 503237 файлы и каталоги установлены.)
Готовится сменить libglib2.0-0 2.33.12+really2.32.4-5 (с помощью .../libglib2.0-0_2.30.0-0ubuntu4_amd64.деб) ...
Распаковка libglib2 замены.0-0 ...
с dpkg: ошибка при обработке файла /var/кэш/АПТ/архив/libglib2.0-0_2.30.0-0ubuntu4_amd64.деб (--распаковать):
 './usr/share/doc/libglib2.0-0/README.gz отличается от той же файл в системе
архив с deb: ошибка: подпроцесс вставка был убит по сигналу (прорвало трубу)
Ошибки возникли при обработке:
в /var/кэш/АПТ/архив/libglib2.0-0_2.30.0-0ubuntu4_amd64.деб
Е: суб-процесс /usr/бен/с dpkg вернул код ошибки (1)
+717
Avery niceman 23 мар. 2018 г., 11:36:48

Я просто попытался установить LBP5050n в Ubuntu 12.04 и работает отлично. Но использовать вместо:

суда /usr на/sbin/ваш любимый редактор для редактирования -п LBP5050 -м CNCUPSLBP5050CAPTK.ППД-в КПК://localhost в:59787 -е

вместо:

суда /usr на/sbin/ваш любимый редактор для редактирования -п LBP5000 -м CNCUPSLBP5000CAPTK.ППД-в КПК://localhost в:59787 -е
+488
sispati 30 янв. 2013 г., 5:25:46

Перейдите на эту ссылку, скачать необходимую .деб на другом компьютере, сохранить его на USB-накопитель, и установить его через центр программного обеспечения.

+466
veta27 12 июн. 2012 г., 20:16:30

Пожалуйста, обновите ваш жратвы и в следующий раз, когда вы загружаетесь в Ubuntu, выберите режим восстановления и обновления загрузчик GRUB.. и потом перезагрузка.. я думаю, это должно решить проблему.

+434
millenium 17 мая 2010 г., 23:00:23

По данным http://www.omgubuntu.co.uk/2013/04/minecraft-installer-for-ubuntu вы можете сделать это:

судо дополнения кв-репозиторий PPA:Майнкрафт-установщик-пищит/Майнкрафт-установщик
судо apt-получить обновление && судо apt-получить установку Майнкрафт-установщик
+429
Geeko 1 июл. 2010 г., 1:42:10

Есть ли способ, чтобы изменить программный настройки в конфигурационный файл или переименовать/интерфейсом dconf?

Пожалуйста, приведите пример конфигурации делается в эту команду и альтернативным методом.

+167
Lala Natividad Pascual 19 нояб. 2014 г., 19:37:29

Возможные Дубликаты:
Как я судо команду в скрипт без запроса пароля?

У меня есть небольшой файл сценария, чтобы запустить Наутилус с правами root. что читает:

gksu Наутилус 

и он запрашивает пароль пользователя root.

Есть ли способ, чтобы автоматически ввести мой пароль в файле скрипта?

Я знаю, что это не безопасная практика, я просто хочу знать, если я могу сделать это.

+154
RickJamesBitch 2 мая 2018 г., 5:43:22

Резюме

Как я могу сделать apt-получить предпочитаю локальный репозиторий пакетов вместо повторной загрузки одного и того же пакета версию из официальных репозиториев? Локальный репозиторий подписан и доверять. Мы уже пробовали кв. приоритетных предпочтений.


Исходный вопрос был : "как назначить высокий приоритет локальное хранилище без использования источников.файл список"

Я настроить локальный репозиторий с пакетами, которые я скачал. Я использую его, чтобы не загружать одни и те же пакеты через Интернет, когда мне нужно переустановить Убунту. Это основной репозиторий, созданный с помощью apt-ftparchive пакеты . > Пакеты. Я сделал это надежное хранилище, чтобы избежать "хранилище непроверенных" предупреждение. (Если у вас ненадежное хранилище, АПТ или синаптической попробовать скачать те же пакеты через Интернет, потому что ей доверяют).

Я использую этот локальный репозиторий не менее 1 года. Но я всегда ставил мой локальный репозиторий линии в верхней части источника.список файл, чтобы использовать это. Но это раздражает, так как я должен открыть терминал и сделать некоторые печатаю на нем каждый раз, когда я переустановить Убунту, хотя есть лучше инструмент программного обеспечения-свойства-ГТК. Я не могу использовать этот инструмент, так как это место исходной строки в конце источники.список.

И настоящая проблема состоит в том, что апта или синаптической всегда скачать пакет из источника, который, как упоминалось ранее, без проверки того, является ли пакеты уже доступны в локальный репозиторий. Так, у меня нет выбора, кроме как размещать локального источника в верхней части источника.список делаем терминал (на самом деле я не ненавижу терминала, но мне нужно решение) .

Я пробовал этот метод. Но это не поможет мне.

Мои предпочтения файл этот в файл/etc/АПТ/предпочтения.д/местного-пин-900

 Пакет: *
 Пин-код: выпуск о=местный,Н=Убунту-местные
 Пин-Приоритет: 900

Мой файл выпустить это

 Происхождение: Местные
 Метки: Локальный-Убунту
 Описание: Локальный Репозиторий В Ubuntu 
 Название: Убунту-местные
Программы md5sum:
 ed43222856d18f389c637ac3d7dd6f85 1043412 пакеты
 d41d8cd98f00b204e9800998ecf8427e 0 источников

Когда я включить АПТ-предпочтений, АПТ-кэша политики правильно показывает предпочтения, например, он показывает локальное хранилище имеет наивысший приоритет.

Но когда я делаю это судо apt-получить установку <имя-пакета>, АПТ пытается скачать его из интернета. Но когда я помещаю мой местный РЕПО на вершине, он устанавливает из локального репозитория.

Итак, мой вопрос -> 'Можно ли заставить склонны использовать локальное хранилище, когда пакет в локальный репозиторий, без явного размещения "местных источников" в верхней части моего репозитория списка (например.г источников.файл список) ?'

Редактировать: выход из АПТ-кэша политика $имя_пакета выглядит следующим образом

Наутилус-стереть:
 Установлено: (нет)
 Кандидат: 0.1.1-2
 Версия таблицы:
 0.1.1-2 0
 500 http://archive.ubuntu.com/ubuntu/ точный/Вселенная пакеты для i386
 Файл 900:/медиа/главная/Linux-софт/Убунту/точная/ пакеты

Это показывает, что мой локальный репозиторий имеет более высокое предпочтение, хотя это не тот, который приходит первым в источниках.список файлов.

Вот вывод apt-получить установку Наутилус-протирать

Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующие новые пакеты будут установлены:
Наутилус-протирать
Обновлено 0, 1 установлено новых, 0 для удаления и 131 не обновляется.
Нужно сделать 30.7 КБ архивов.
После этой операции, 150 КБ дополнительное дисковое пространство будет использоваться.
'http://archive.ubuntu.com/ubuntu/pool/universe/n/nautilus-wipe/nautilus-wipe_0.1.1-2_i386.deb' Наутилус-wipe_0.1.1-2_i386.деб программы md5sum 30730:7d497b8dfcefe1c0b51a45f3b0466994

Он все еще пытается получить файл из интернета, хотя я думаю, что он должен быть счастлив с местными.


Результат использования "" или localhost в качестве mediageek предложил

С помощью localhost не имеет никакого эффекта. но "" есть, но не отличается, чем мой способ

 Пакет: *
 Пин: происхождение ""
 Пин-Приоритет: 1001

Я использовал их, прежде чем отправлять вопрос. Но опять же я пробовал это (для безопасности). Один и тот же результат. АПТ-кэша политики , показывая, что мой локальный репозиторий действительно имеет наивысший приоритет. но когда я попытался установить его, говорит: "Надо вам ХХХ/ХХХ КБ в архиве".

+131
Facebook Questions 15 янв. 2018 г., 18:58:41
Snort является открытым исходным кодом, предотвращения сетевых вторжений и системы обнаружения (IDS и IPS)
+12
level1 25 февр. 2019 г., 18:58:21

Я пытаюсь установить Ubuntu на окна 7 виртуальный ПК, когда я загрузиться в Ubuntu с ISO образа как раз перед разделов стадии, когда Убунту подтверждает у вас в leaset 4 ГБ Место на жестком диске установщик ставит крест на требование с указанием в системе не будет необходимого пространства...

однако у меня есть 220GB жесткий диск с 20 ГБ, используемый для создания виртуального диска..его все немного странно, как я не могу выяснить это

+10
mark coder 25 июл. 2013 г., 22:22:32

Показать вопросы с тегом